Silvan Michael Gebhardt bio photo

Silvan Michael Gebhardt

Unternehmer, Informatiker, Network Operator

Twitter LinkedIn

Further triaging

as I already blogged I can’t get my ssh to work on 14.04 on some (upgraded btw from working 13.10 status) machines.

##sshing after boot:

ssh: connect to host localhost port 22: Connection refused

Removing SSH

What I tried is to completely purge sshd:

pcdog@ws-silvan-ubuntu ~ % sudo apt-get remove --purge openssh-server
[sudo] password for pcdog: 
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:
  libssl0.9.8
Verwenden Sie »apt-get autoremove«, um es zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  openssh-server* ssh*
0 aktualisiert, 0 neu installiert, 2 zu entfernen und 85 nicht aktualisiert.
Nach dieser Operation werden 981 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] J
(Lese Datenbank ... 433249 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von ssh (1:6.6p1-2ubuntu2) ...
Entfernen von openssh-server (1:6.6p1-2ubuntu2) ...
ssh stop/waiting
Löschen der Konfigurationsdateien von openssh-server (1:6.6p1-2ubuntu2) ...
userdel: Eintrag »sshd« konnte nicht aus /etc/passwd entfernt werden.
/usr/sbin/deluser: »/usr/sbin/userdel sshd« gab den Fehlercode 1 zurück. Programmende.
Trigger für man-db (2.6.7.1-1) werden verarbeitet ...
  • I can’t get why this user is missing.
  • I tried to reinstall openssh-server afterwards, it does at least start the service but after a reboot sshd ist not booted up, and it shows this error message in dmesg: [ 248.832366] init: ssh main process (1575) terminated with status 255 [ 248.832384] init: ssh main process ended, respawning
  • I don’t seem to have an user sshd in /etc/passwd post reinstallation so I am currently out of ideas….
  • It happens on a machine where only iface lo is in the /etc/network/interfaces AS WELL as on a machine wher I have both ipv4 and ipv6 configured static so I don’t think it has too much to do with network manager waiting for interface config

Hints?